Degraded Valuation Performance

Incident Report for ChathamDirect

Resolved

This issue has been resolved.
Posted Dec 19, 2025 - 15:51 EST

Monitoring

Affected services have been restored to normal operation. We will continue to monitor the system to ensure this has been completely resolved and will update when we have any additional information to share.
Posted Dec 19, 2025 - 10:53 EST

Update

We are continuing to investigate the root cause of this issue.
Posted Dec 19, 2025 - 10:32 EST

Investigating

We are experiencing issues that impact pricing derivatives.

Our team is investigating the root cause of the issue. Thank you for your patience.
Posted Dec 19, 2025 - 10:00 EST