cf.com Login

Incident Report for ChathamDirect

Resolved

This incident has been resolved. Thank you for your patience while we worked through this.
Posted Apr 21, 2026 - 18:08 EDT

Monitoring

The team has implemented the fix and the affected services have been restored to normal operation. We will continue to monitor the system to ensure this has been completely resolved and will update when we have any additional information to share.
Posted Apr 21, 2026 - 18:06 EDT

Investigating

We are experiencing issues that impact the ability to login to cf.com.

Our team is investigating the root cause of the issue. Thank you for your patience.
Posted Apr 21, 2026 - 18:02 EDT